POP3 clients that break here, they violate STD53

General Discussion about General things

Moderators: Havokmon, linkchaser

Post Reply
kikoucalou
Posts: 4
Joined: Fri Nov 17, 2006 2:24 am
Location: france
Contact:

POP3 clients that break here, they violate STD53

Post by kikoucalou » Fri Nov 17, 2006 2:41 am

Bonjour,

I am using Sylphee-claws on debian

version 2.6.0
ISO-8859-15
Linux 2.6.18-2-k7 (i686)
with options : IPv6 iconv compface OpenSSL LDAP JPilot GNU/aspell libetpan libgnomeprint libSM

when getting mail it's appear a violation rule error : STD53

[08:09:57] POP3< +OK
[08:09:57] POP3> LIST
[08:09:57] POP3< +OK POP3 clients that break here, they violate STD53.
[08:09:57] POP3> RETR 1
[08:09:58] POP3< +OK 60167 octets follow.

Does somebody could explain what is wrong?
Do you know if that is a specfic sylpheed-claws bug of some mistake in config ?

Thanks and B.RGDS

Pascal LACROIX
Pascal LACROIX

http://kikoucalou.chez-alice.fr
La vie est pleine d'une infinité d'absurdités, qui, impudemment, n'ont
même pas besoin de paraître vraisemblables; car elles sont vraies.

User avatar
Havokmon
Site Admin
Posts: 1547
Joined: Wed Jul 02, 2003 11:17 am
Location: WI
Contact:

Post by Havokmon » Fri Nov 17, 2006 8:30 am

I'd say it's a problem with the sylpheed client. This is why:

08:09:57] POP3< +OK
[08:09:57] POP3> LIST
[08:09:57] POP3< +OK POP3 clients that break here, they violate STD53.
[08:09:57] POP3> RETR 1
[08:09:58] POP3< +OK 60167 octets follow.

The LIST command lists all the emails in your INBOX. From what you posted, there was nothing there. Then sylpheed issues a RETR command with a 1 to get the message with an index of 1 - but there isn't any. I guess that's why the STD53 message is there, the client should know that without an array of returned messages, there shouldn't be anything to retrieve :(

Maybe you could use fetchmail to pull your email into your local mbox and have Slypheed-claws read mail from there? Either that, or let the devs know and I would think that's an easy fix.

Rick
VFEmail.net Admin

kikoucalou
Posts: 4
Joined: Fri Nov 17, 2006 2:24 am
Location: france
Contact:

Post by kikoucalou » Fri Nov 17, 2006 3:45 pm

Rick,

her, its an answer from Sylpheed-claws developers

> I recieve an explaination from VFEmail admin
>
> "posted: Fri Nov 17, 2006 7:30 am Post subject: Reply with
> quote I'd say it's a problem with the sylpheed client. This is why:
>
> 08:09:57] POP3< +OK
> [08:09:57] POP3> LIST
> [08:09:57] POP3< +OK POP3 clients that break here, they violate STD53.
> [08:09:57] POP3> RETR 1
> [08:09:58] POP3< +OK 60167 octets follow.
>
> The LIST command lists all the emails in your INBOX. From what you
> posted, there was nothing there. Then sylpheed issues a RETR command
> with a 1 to get the message with an index of 1 - but there isn't any. I
> guess that's why the STD53 message is there, the client should know
> that without an array of returned messages, there shouldn't be anything
> to retrieve

So, as there is nothing to retrieve, ask the admin guy why the server
sends you 60167 octets of nothing?

--

Brian Morrison

bdm at fenrir dot org dot uk

GnuPG key ID DE32E5C5 - http://wwwkeys.uk.pgp.net/pgpnet/wwwkeys.html

They do not agree whith you, probably you can understand them.

Anyway, as I am not a mailer specialist, this may be bug does not disturbe me, my sylpheed-claws do the job and I am happy whith vfemail.

B. RGDS
Pascal LACROIX

http://kikoucalou.chez-alice.fr
La vie est pleine d'une infinité d'absurdités, qui, impudemment, n'ont
même pas besoin de paraître vraisemblables; car elles sont vraies.

User avatar
Havokmon
Site Admin
Posts: 1547
Joined: Wed Jul 02, 2003 11:17 am
Location: WI
Contact:

Post by Havokmon » Fri Nov 17, 2006 4:09 pm

Hmm Good point.

What's your username? I need to see what it looks like from a telnet session. It might be that the debug log there just doesn't show the returned list, even though there is something there. Then we can look at what '1' is.

You can email it to 'admin@vfemail.net' if you like.

Rick
VFEmail.net Admin

User avatar
Havokmon
Site Admin
Posts: 1547
Joined: Wed Jul 02, 2003 11:17 am
Location: WI
Contact:

Post by Havokmon » Fri Nov 17, 2006 4:17 pm

Wait a moment - maybe I didn't understand the question.

Are you just asking what that message means, and your client works fine?
If that's the case - The message is just informational, it's there to let the developer know that if there is a problem it's probably due to improper implementation of STD 53. It always appears, whether or not there's a problem.

Rick
VFEmail.net Admin

kikoucalou
Posts: 4
Joined: Fri Nov 17, 2006 2:24 am
Location: france
Contact:

Post by kikoucalou » Fri Nov 17, 2006 4:41 pm

Rick,

my client appear working fine. This message have always been since my first using of vfemail.

Just, by this time I dont pay attention to him.

Recently, I was testing and watching some logs when I realise that worning from you.

He appear every time.

You will recieve my username by private mail

Best Regards
Pascal LACROIX

http://kikoucalou.chez-alice.fr
La vie est pleine d'une infinité d'absurdités, qui, impudemment, n'ont
même pas besoin de paraître vraisemblables; car elles sont vraies.

User avatar
Havokmon
Site Admin
Posts: 1547
Joined: Wed Jul 02, 2003 11:17 am
Location: WI
Contact:

Post by Havokmon » Fri Nov 17, 2006 5:42 pm

Ok. My apologies, I misunderstood.

There is no issue. It's just an informational message.

Rick
VFEmail.net Admin

kikoucalou
Posts: 4
Joined: Fri Nov 17, 2006 2:24 am
Location: france
Contact:

Post by kikoucalou » Fri Nov 17, 2006 6:16 pm

Rick,

Thanks, everything is ok its an informational message.

Important is no bug in sylpheed-claws or debian relative packages and vfemail.

Bonne continuation !

B. Rgds
Pascal LACROIX

http://kikoucalou.chez-alice.fr
La vie est pleine d'une infinité d'absurdités, qui, impudemment, n'ont
même pas besoin de paraître vraisemblables; car elles sont vraies.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests